このページは福井県立大学の田中求之が2006年1月まで運用していた Mac のサーバ運用に関する会議室 「Web Scripter's Meeting」の記録です。情報が古くなっている可能性がありますのでご注意ください。

Internet Exploreの文字化け

発言者:LAPSHA
( Date Monday, January 26, 2004 09:29:52 )


いつも勉強させていただいております。

MAC OSX10.2からOSX10.3にアップデートした環境でMicrosoft Internet
Explorer5.2.3を使用しているのですが、特定のユーザ名でシステムに
ログインした場合だけメニューやダイアログボックが文字化けします。
別のユーザでシステムにログインした場合は問題ありません。
文字化けするユーザの「ホーム」−「ライブラリ」−「Preferences」
に入っている「Explorer」フォルダを削除してInternet Explorerを
立ち上げ直してみたのですが改善しません。
対処方法をお教えください。よろしくお願いします。

田中求之 さんからのコメント
( Monday, January 26, 2004 12:50:11 )

システム環境の言語環境で、日本語が最優先の言語になってますよね?

あとは、[並べ替えをカスタマイズ…]をクリックして出てくるスクリプトの
割当設定で、日本語には日本語が割り当てられていますよね?

こういう単純な問題ではないとは思いますが、念のため、確認です。

LAPSHA さんからのコメント
( Monday, January 26, 2004 13:57:48 )

ご回答ありがとうございます。
ご指摘の点ですが、どちらも正しく設定されていると思います(すみません。手元の
パソコンではないので確認できません)。ただ、Safariではちゃんとメニューもダイ
アログボックスも日本語で表示されますので、問題ないかと考えています。

torazou さんからのコメント
( Monday, February 02, 2004 09:43:41 )

初めまして。ぼくも同じ症状で困っています。いろいろ検索してるうちにこのホームページに辿り着きました。
 症状の確認をしたいのですが、ぼくの「お気に入り」「履歴」etcなどのサイドメニューがアラビア語のような文字化けをします。しかし、内容は確認できます。アプリケーションを捨て、新しいIE5をダウンロードしてもかわりませんでした。
 これとは関係ないかもしれませんが、enturage、mailの設定、内容も消えてしまいました。御存知の方がおられましたが御指導のほど宜しくお願いいたします。

snappish さんからのコメント
( Monday, February 02, 2004 11:11:40 )

Internet Exploreの文字化けは私の経験上
/Users/ユーザー名/.CFUserTextEncoding
このファイルは不可視ファイルです
このファイルが破損したり削除されてしまったりして発生する
事が多いです。
.CFUserTextEncodingの中身は普通のテキストファイルで
1:14

と入っていればokです。
お試しを
ちなみにサーバー関連以外の質問は
『Mac OSの使い方 掲示板』とか(一般的なmac関連の掲示板)の方が
より良い回答を聞けると思いますよ。

http://bbs8.otd.co.jp/macos/bbs_thread



yasu さんからのコメント
( Tuesday, February 03, 2004 22:32:29 )

trazouさんへ
以下のページの解決法を試してみて下さい.
僕は同じ現象でしたが,うまくいきました.
http://support.microsoft.com/default.aspx?scid=kb;ja;826428

LAPSHA さんからのコメント
( Friday, February 13, 2004 15:02:49 )

皆様、いろいろアドバイスありがとうございました。
おかげさまで無事問題解決いたしました。
結局、問題のユーザーのホームに .CFUserTextEncoding そのものが存在せず、
文字化けを起こしていたようです。
別ユーザーの同ファイルをコピーしてきたところ、無事文字化けが解消いたしました。
ありがとうございました。

yoru さんからのコメント
( Thursday, February 26, 2004 16:54:20 )

ここで発言するのが間違っていたら申し訳ありません。
Macの事は良く分からず今まで手探りで自サイトを運営して来ました。OS9.2でAdobe GoLive 5.0を使いアップロードしたこれまでのサイトは新しく買ったiNac、OSX10.2.7のIE5.2で問題なく表示されるのですが、OSX10.2.7でAdobe GoLive 5.0を使いアップロードしたサイトが文字化けしてしまいます。GoLive 5.0がOSXに対応していない所為でしょうか。htmlやFTPに詳しい方、何か解決タグか方法を教えて頂きたく思います。私のサイトは版権を扱った同人サイトです。ご注意下さい。
注文だけの失礼な発言で本当に申し訳ありません。
yoru拝

→  心音(同人サイトです)

ダストバニ さんからのコメント
( Thursday, February 26, 2004 23:15:06 )

yoru殿

>間違っていたら申し訳ありません。

お察しの通り、間違っています。
が一つフォローしますれば… サイトの元ソースを全部テキストエディタ等で開き、
テキストコード指定をコツコツ確認。誤りを修正しGoLiveではなく汎用ftpツールにて
サーバへ送信。これが駄目ならWebクリエータ主催の板でhelpしてみて下さい。成功を祈念いたしまする。

おせっかい さんからのコメント
( Friday, February 27, 2004 10:33:35 )

ここではこの様な話題は適切ではないと思いますが…。

yoruさん、METAタグが間違ってますね。
リンクされているサイトでは、
<meta http-equiv="content-type" content="text/html;charset=X-MAC-JAPANESE">
となっていますが、この文字コード指定では文字化けするでしょう。
#しかし、X-MAC-JAPANESE ってすごいな…
GoLiveは使ったことがないので詳しくは知りませんが、
恐らくどこかで文字コードの設定ができるんじゃないでしょうか。

ちなみに文字コードがシフトJISなら以下のようになります。
<META http-equiv="Content-Type" content="text/html;charset=Shift_JIS">

METAタグ、文字コード、などで検索してみてください。
すぐに詳しい情報が見つかるでしょう。

修正後は、ダストバニさんがおっしゃるように汎用FTPツールでアップした方が安全でしょうね。