このページは福井県立大学の田中求之が2006年1月まで運用していた Mac のサーバ運用に関する会議室 「Web Scripter's Meeting」の記録です。情報が古くなっている可能性がありますのでご注意ください。

AppleShare IP MailServerの不調について

発言者:birdeyed
( Date Friday, September 07, 2001 10:21:02 )


はじめまして。
Macintosh G4 ServerとAppleShare IP 6.1でLANを組んでいます。
OSは9.1で、クライアント数は10台です。
が、MailServerが時々「カシャコン、カシャコン」とHDにアクセスを
始めるようで、それによってサーバが停止してしまいます。
リストアすると回復するのですが、しばらくすると同じ状態になって
しまいます。
MailServerなりASIPなりの設定が間違っているのか、不要なファイル
があるのか、壊れたファイルがあるのかと、色々試してみるのですが、
よくわかりません。
ご存知の方がおいででしたら、ご教示をよろしくお願いいたします。

稲垣 さんからのコメント
( Friday, September 07, 2001 10:37:14 )

 HDが異音を出しているのであれば、HDが壊れかけているのかと思います。

 私も突然異音を出すようになり、読み出せないファイルが出てしまった
ので交換をしたことがあります。
 また、HDごとにも当たり外れがあるようですが、今まで壊れてしまった
ものは1年も使っていないのに壊れてしまっていますので、最近購入したか
らと、余り信頼しすぎるのも良くないようです。
#個人的な経験ではIBM製のHDが一番信頼できます。

 私ならHDを交換します。今であれば、ファイルの損失などがほぼ無く改善
出来るのかなと思います。

 それ以外だと、熱暴走か電力が不安定で挙動不審になっているかもしれ
ません。

田中求之 さんからのコメント
( Friday, September 07, 2001 17:20:34 )

>HDが異音を出しているのであれば、HDが壊れかけているのかと思います。

私もそう思います。ドライブ設定や Norton のようなディスク・ユーティリティを使って
ハードでディスクのチェックを行ってみてください(もっとも、ディスクが壊れている
場合には、このチェックすら終了できなくなりますが)。

birdeyed さんからのコメント
( Saturday, September 08, 2001 00:25:01 )

コメントありがとうございます。
ディスク・ユーティリティを使うかぎりでは、HDに異常は見つかりません。
また、HDへの異音を立ててのアクセスは、MailServerの起動時と終了時、また
はMailServerの設定変更を試みる時に限られます。
現在、MailServerの使用を中止していますが、同様の現象は発生していません。
トピックのタイトルを「MailServerの不調」としたのも、それを根拠にしてい
ます。
MailServerの使うファイルの不調かとも思いましたが、よくわかりません。
幸い、ファイルの読み書きなど、他の作業にも支障は出ていません。
でも、いきなりHDが壊れたらいやだな……バックアップしときます。

birdeyed さんからのコメント
( Saturday, September 08, 2001 01:26:22 )

上のコメントがちょっと説明不足なので、自己レスです。

> HDへの異音を立ててのアクセスは、MailServerの起動時と終了時、また
> はMailServerの設定変更を試みる時に限られます

だったのが、通常の使用時にも突然同じような状態に突入してしまい、
サーバーへのアクセスが止まるという症状が出始めたのです。
起動時と終了時だけだったら、「ま、いっか」で使い続けちゃうんですが。

北見 さんからのコメント
( Saturday, September 08, 2001 11:25:24 )

データベースを読みに行っている音だと思います。

データベースファイルが大きくなっていませんか?

AppleShare IP Mailholderの中のde-taの容量が大きくなっているのではないでしょうか?

メールホストの数はどうでしょうか?

>だったのが、通常の使用時にも突然同じような状態に突入してしまい、
>サーバーへのアクセスが止まるという症状が出始めたのです。

メールのログは正常ですか。


p さんからのコメント
( Monday, September 10, 2001 09:53:21 )

spam?
踏み台にされてるとか。

birdeyed さんからのコメント
( Wednesday, September 19, 2001 21:48:14 )

コメントありがとうございます。
課室内のみのLANなので、spamではないと思うんですが。
結局、よくわからないままASIPごとリストアしてしまいました。
しばらく使ってみて、また問題が出てきたら、ご教導お願いいたします。