このページは福井県立大学の田中求之が2006年1月まで運用していた Mac のサーバ運用に関する会議室 「Web Scripter's Meeting」の記録です。情報が古くなっている可能性がありますのでご注意ください。

8.6+9.0+X-Server+X-PB

発言者:中嶋
( Date Sunday, November 19, 2000 18:20:18 )


Power Macintosh G3 DT300 Graphic Editionに、
MacOS 8.6,9.0,X-Server,X-PBを、インストールしました。

同じ様な環境を作りたくても、恐くてできない人が居ると思いますので、
インストール時の手順と、現在の使い勝手を、報告しておきます。

機器構成:
UltraWideSCSI3ボード(アップル純正)に、純製ドライブ×1、非純製ドライブ×2
外づけ、SCSI2ドライブ×1
内蔵graphicカード+PCIGraphicカード(アップル純正)
メモリ256MB

ディスク構成:
純製SCSI3ドライブ(1パーティション)に、X-Serverをインストール済み
SCSI3非純製ドライブ(2パーティション)に8.6(マイクロソフト追放)をインストール
 2つ目のパーティションは、UFSとHFS+の間でデータを交換するために利用
外づけSCSI2ドライブ(1パーティション)に8.6(ワード・エクセル用)をインストール
最後のSCSI3非純製ドライブに、9.0と、X-PBをインストール
 使うソフトの都合上、2パーティションに分けて、
 後ろのパーティションは、文書用として、使用
  (MacDrawProが、1GB以上のディスクを使用するとエラーを起こすため)
フォーマットは、全てB'sCrewで行いました。

インストール:
9.0をインストール後、9.04にバージョンアップ(必須)
UltraSCSI3ボードのファームウェアアプッデートをする(GraphicEditionのみ)。
インストール用CDから起動してすぐに、KernelPanicで停止。
試しに、PCIGraphicカード側のディスプレイケーブルをひっこ抜いたら、
あっさりと、CDから起動し、インストールも正常に終了。
X-PBが起動するが、PCIGraphicカード側のディスプレイケーブルを入れると、
必ずKernelPanicで停止(原因不明)。
なお、X-Serverのパーティションは、見えない。
PB上でのコンパイルが、X-Serverより、遅い(20%程度の速度)ため、
UFSで再インストールすることを、決意。
ディスクを丸ごと再フォーマットし、2パーティションに分けて、
両方HFS+として、前に9.0をインストールし、9.04へアップ。
PBのCDで、後ろのパーティションをUFSに指定して、インストール。
インストールは正常に終了し、PBは、起動した。
しかし、同じUFSであるにもかかわらず、相変わらずX-Serverのパーティションは見えない。
なお、コンパイル速度は、X-Server並に向上した。
しかし、Classic環境は、起動はしたが、やたらめったら吹っ飛ぶ。
さらに、雑誌に載っていたようなメニューの不具合が生じ、使用を断念。
再び、ディスク丸ごと再フォーマットして、9.0&PBをインストール。
PBから、9.0を起動すると、吹っ飛ぶ????
ATOKの出すフローティングパレットが、見えた瞬間からおかしくなるので、
ことえりに戻したところ、正常に起動。
恐る恐るATOKも、インストールしてみたが、一度正常起動した後は、
問題なく動作している。
PB上でのコンパイル速度は、X-Serverとほぼ同じ(あれ????????)。

使い勝手:
9.0(通常)からPBへの切り替えは、新しいSystemDiskコントロールパネルで一発。
PBから、9.0も同様。
しかし、PBから、8.6へは、一旦9.0に切り替えてから、
古いシステムディスクコンパネで切り替えて、さらに、Optionキーを押して起動。
X-Server側のファイルをPBに持ってくるのは、さらに大変で、
X-Serverで起動して、ファイルを、データ交換用ディスクにコピーして、
Optionキーを押しながら、再起動して8.6、
9.0へ切り替えて再起動して、PBに切り替えて再起動、、、、、、、、、
通常使う分には、Classicは、問題なく動作しており、実用上支障無いです。
ただ、PB<->Classic間で、ドラッグ&ドロップを行うと、Classicが飛ぶ様です。
PBのソフト間で、D&Dをやっているつもりでも、
Classicのウインドウをかすると、Classicが丸ごと飛びます。