このページは福井県立大学の田中求之が2006年1月まで運用していた Mac のサーバ運用に関する会議室 「Web Scripter's Meeting」の記録です。情報が古くなっている可能性がありますのでご注意ください。

AppleShareIPで送りだしたPDFファイルがエラーになる珍現象?

発言者:藤川
( Date Friday, November 10, 2000 21:56:45 )


ひさしぶりに書き込みさせていただきます。
以前から社内用にWEBTENでサーバ運用をしていたのですが
今回G4cubeとAppleShareIP6(50クライアント)の組み合わせで新たにサーバをたてようとしております。

で、今まで運用してきたコンテンツを ここ数日 G4cubeへ移植しWEB動作の確認
をしていたところ、なぜかPDFファイルが、(Acrobatのエラーで)表示ができ
ない、場合によってはブラウザがクラシュしてまう珍現象?が起きてしまい原
因がわからず困っております。

状況と自分なりの疑問点をもうすこし細かくいいますと...

1.問題のPDFファイルは製品のマニュアルをスキャンしたもので数M〜10M位と結
構(容量、ページ数とも)デカイ。なおファイルの破損の有無については、同
じものを再度WEBTENとついでにLINUXのサーバ経由でも落としてみて異常がおき
ないところをみると、多分瑕疵はないと思う。

2.HTMLからのリンクでpdfを表示しようとすると、最初のページは表示される
が、他のページへ移ろうとするとエラーアラートが出て白紙表示、またはブラ
ウザがアイドル状態にようになってしまう。

3.WEBサーバのMIME設定の問題か?(しかしデフォルトのままである)

4.KeepAliveのタイムアウトの時間設定?
AppleShareIP6 のWEBのKeepAliveのタイムアウトはデフォルトで120sとなって
いる。しかし WEBTENでは15sである。この差が何かしらの要因になるのだろか?

5.もう少し注意深く見ていると、PDFをブラウザで受信していると、500kbくら
いで一旦転送が止まってしまうように見える。ちなみにサイズの小さい(100k
くらい)のものではこの現象は起きないようだ。

6.そういえばHTMLページでjpg画像を100点くらい張り付けたものも、途中で転送が
止まってる(?)ような現象があった。

と考えると、PDFというよりも、どうも大きなデータの送出についての障害によ
うです。

ASIPに限らず、WEBサーバでこれに似たような現象を御経験されたことがあれば
ぜひ、情報をいただければ嬉しく思います。

よろしくお願いいたします。



田中求之 さんからのコメント
( Friday, November 10, 2000 22:34:24 )

>PDFというよりも、どうも大きなデータの送出についての障害によ
>うです。

私自身の MP3 のコレクションの管理に ASIP の Web サーバを使っているのですが
(聴きたくなったら、いつでもデータを持ってこれるように (^_^;; )、数M〜20M
クラスのファイルを Web でバンバン転送しても、何のトラブルも起きていませんよ。

ただ、ASIP の Web サーバについては、今一つ、私は信用できない気はしてますが。

システムに付属の Web 共有に切り替えてみて、転送がうまくいくかどうか試されては
どうですか? うまくいくようであれば、ASIP の問題ということがはっきりしますよ
ね。

藤川 さんからのコメント
( Friday, November 10, 2000 23:18:55 )

田中先生レスありがとうございます。
>数M〜20Mクラスのファイルを Web でバンバン転送しても、何のトラブル
>も起きていませんよ。

ん〜そうですか...。
ちなみに、PDFをプラグインでブラウザ内で表示しない設定にして
ダウンロードさせて一旦ローカルに保存してAcrobatで開くと、
ちゃんと見られます。
ただブラウザ内だとNGなんだな〜なぜ??
自分の環境のエラー(プラグインや Acrobatの破損)も考えましたが
自分以外の環境(WindowsのIE5)でも同じ現象が起きました。


>Web 共有に切り替えてみて、転送がうまくいくかどうか試されては
> どうですか?

なるほど。月曜に試してみます。



藤川 さんからのコメント
( Monday, November 13, 2000 15:09:16 )

> >Web 共有に切り替えてみて、転送がうまくいくかどうか試されては
> > どうですか?

> なるほど。月曜に試してみます。
自己レスです。

なんと Web 共有では、全く問題がありませんでした。
と、なるといよいよASIPに問題がようです。
それともASIP自体がこわれてる可能性もあるのかな?


藤川 さんからのコメント
( Tuesday, November 14, 2000 20:34:04 )

自己レスです。
しょうがないので今日アップルのサポートに電話してみました。
案の定解決できなかったのですが、
とりあえず6.3を6.3.2にアップデートしてみたらどうだと言うので
明日試してみようかと思います。

あとは最悪は再インストールかな。
でもそれはやだな。
また設定いちからやり直しするかと思うとゾっとする。

さんからのコメント
( Tuesday, November 14, 2000 23:39:45 )

私の研究室でサーバとして利用しているcubeは6.3.2へアップデートしたら
立ち上がらなくなってしまいました!!。6.3を再インストールしてもだめで
えらくあせってしまいました。結局、初期設定ファイルを削除してやっと
6.3で立ち上がって、今のところご機嫌で動いています。
原因は分かりませんが、webページの連絡用にメールサーバ機能も使ってい
てその立ち上げで止まってしまいましたので、offにすれば何とかなったかも。
機能拡張マネジャーをみると6.3.2のファイルも残っていますが怖くていじっ
ていません。
気をつけて下さい!?。



藤川 さんからのコメント
( Wednesday, November 15, 2000 09:15:04 )

辻 さん、こんにちは。

>私の研究室でサーバとして利用しているcubeは6.3.2へアップデートしたら
>立ち上がらなくなってしまいました!!

えっ本当ですか!?
そいつは困ったな...。
リカバリ(現状のフルバックアップ)対策をしっかりして挑んでみます。

あかめ さんからのコメント
( Monday, November 20, 2000 15:09:16 )

私のところではフォルダ容量で数百Mのものを送り出す(フォルダ丸ごと
コピー)の際に2度ほど、サーバがフリーズしました(ASIP6.3.1+G3/450)。

その際に情報収集したところ
Apple Share IP Black Magic に OT Auto Push Support 機能拡張と
関連があるようだとの記載がありました。

実際には、サーバと同じテストマシンを確保できなかったので、上記サーバでは
運用でカバー(100Mを超えるデータのやりとり禁止)としましたので、検証
はしておりません。

藤川 さんからのコメント
( Thursday, November 23, 2000 12:49:13 )

その後の経過報告です。
結論から言いますと、「直ったよ〜んん(^^)」
ASIP6.3.1と、AppleShare IP Web & File6.3.2の
各アップデータをかけたところ
幸いにもクラッシュすることなく
この現象はピタっと止まりました。

ただ、本当にこれが原因だったかについては何ともいえないところが
あります。
というのは、アップデートする前に、念のため Disk First Aidで
検査したところ、障害が発覚したからです。
内容的にはアイコン表示の不正?というアラートだったので
今回の現象に直接影響を与えるようなものではないのかもしれませんが...。

いったい何がだめだったのか検証が不十分ですが...
まあ、とにかく直ってよかったよ〜〜....。

サーバ運用は結果オーライと見つけたり!?