このページは福井県立大学の田中求之が2006年1月まで運用していた Mac のサーバ運用に関する会議室 「Web Scripter's Meeting」の記録です。情報が古くなっている可能性がありますのでご注意ください。

QPQ1.0.2でのEasyBBS PIのエラー

発言者:masahiro
( Date Wednesday, August 30, 2000 14:19:22 )


LC630(KT7.5.3)にてQPQ1.0.2を動かしています。
QPQ割り当てメモリ6000kです。
Pulg inの認識は旨くいっているようです。

#ADMIN PLUGIN: Running.
#* EasyBBS-plugin installed. とでます。

 http://192.168.0.*/BBS/top.bbsと入力すると
#An error occurred while processing your request.
#An unspecified internal server error occurred.
というアラートがでます。
これを回避するにはどうすればいいのでしょうか?

田中求之 さんからのコメント
( Thursday, August 31, 2000 13:44:00 )

EasyBBS PI のバージョンはいくつですか?

ゆうれい さんからのコメント
( Thursday, August 31, 2000 13:56:56 )

Opentransport,QPQ1.02,netscape,EasyBBS PI1.0b3
の組み合わせでは成功したことがあります。

1.0b3の他に1.0b5がテスト中ですよね確か、動作報告はほとんど聞きませんが、

あとは田中求之さんの過去の発言で
IE5.0はCPU占有時間が長い?ので同一マシンで
掲示板をIE5.0での動作確認は行わないほうが良いというのが
あったはずです。

おまけ、IE5.0はアップルルームで仕様(バグ)がある程度わかります。
http://www.appleroom.com/application/ie5bug.html

ゆうれい さんからのコメント
( Thursday, August 31, 2000 14:00:04 )

IE5.0を使っている可能性は少ないか・・・。

masahiro さんからのコメント
( Thursday, August 31, 2000 18:22:50 )

田中様>
EasyBBS PI 1.0b3 (200K)をダウンロードしてきました。
QPQへの割り当てメモリの問題でしょうか?現状ではこれ以上は割り当てられないです
(もっともこれが原因なら他のMacから移植するしかないですね)

ゆうれい様>
LC630ですから。。QPQ専用マシンにしています。
(モニタ繋いでないにで動作確認でTimbukutuは入れてますけど)
Netscapeは入れていません。動作の確認には別のMacのNetscapeにて行いました。
MacTCPが入ってますからOpentransportじゃないのかもしれないです。

前薗 健一 さんからのコメント
( Monday, September 04, 2000 21:07:23 )

東京に出張中だったため、コメントが遅くなりました。

> http://192.168.0.*/BBS/top.bbs

の * って伏せ字ですか?それとも実際にそういうオペレーションをしているのでしょうか?

バージョンは 1.0b5 が最新です。

masahiro さんからのコメント
( Monday, September 04, 2000 22:51:24 )

前薗様>
すみません。伏せ字にしています。
192.168.0.7/BBS/top.bbsという感じです。
将来は***.dyndns.org/BBS/top.bbsという形になります。
ASIPに入れて実験しましたらうまくいきました@EasyBBS
同じ様な感じで設定したと思うのですが。。。
(あと630に試しに入れたfreeboard2.2は問題なく動いています。)
しかし動きの軽さを考えるとLC630ではEasyBBSが良いような感じがします。

前薗 健一 さんからのコメント
( Tuesday, September 05, 2000 14:34:22 )

QPQ のエラーの意味は

リクエスト処理中にエラーが発生しました。
未定義のサーバ内部エラーです。

てな感じですよね。ちょっと私には解決策は判りません。
私は QPQ は持っていないし、使ったこともありませんので推測ですが、
QPQ 側で何か設定があるのではないでしょうか?

たまちゃん さんからのコメント
( Tuesday, September 05, 2000 20:35:04 )

QPQ 2.1.3 で試してもらえますか?

masahiro さんからのコメント
( Saturday, September 09, 2000 09:18:16 )

たまちゃん様>
QPQの新しいのを落としてきましたが、少しバタバタしてますので少しお時間をください。

masahiro さんからのコメント
( Saturday, September 30, 2000 18:01:34 )

たまちゃん様>
随分遅くなりましたが確認しました。
QPQ2.1.3では1.0b3は認識し、動作しました。
現状では問題はでていません。レスポンスも悪く有りません。
(SE/30+Booster30-50 KT7.5.5 RAM68M QPQ割り当て12000)
しかし1.0b5は動作しませんでした。1.0b3が動きますので支障はないですね。
マシン環境から考えればQPQ1.0.2なのかもしれませんが2.1.3の方がレスポンスが
いいような感じがします。

masahiro さんからのコメント
( Sunday, October 01, 2000 23:24:10 )

追記です。2.1.3がレスポンスがいいというのは勘違いでした。
やはり1.0.2が反応良いようです。
ところでQPQ2.1.3で認識した1.0b3ですが会議室が1つしか使えません。
room2には書き込んでも反映されないのです(ネスケ4.7)
せっかくの軽い掲示板ですから何とか使いたいので格闘してみます。

masahiro さんからのコメント
( Monday, October 02, 2000 21:58:10 )

自己レス連続でも済みません。
会議室は使えないのではなくて更新が反映されていないだけみたいです。
ネスケでの読み込みの時にshiftを押しながら最読み込みすると読めます。
ということで他で話題になっているキャッシュ絡みではないかと推察しています。