このページは福井県立大学の田中求之が2006年1月まで運用していた Mac のサーバ運用に関する会議室 「Web Scripter's Meeting」の記録です。情報が古くなっている可能性がありますのでご注意ください。

SIMSのSMTP time-out

発言者:芝田
( Date Monday, August 21, 2000 22:28:45 )


これまで研究室のメールサーバにSIMSを使っていました。つい最近うちの大学はシステムの入れ替えをしたのですが、その後、外部からのメールが受け取れなくなってしまいました。システム変更と直接関係あるかどうかはまだ分からないのですが、ログを見るとSMTP接続の最中にtime-outをおこして切断されてしまう様です。
そこで、試しにEIMSのDEMO版(3.0)を使用してみたところ、問題なくメールの送受信ができるようになりました。
 当面EIMSでその場しのぎをするにしても、試用期限がきれるまでに原因を突き止めねばなりません。しかし現段階では全くその原因の見当がつきません。いったい何がおかしいのでしょうか。


20:04:50 4 SMTP-002() Got connection from [***.***.***.***:*****]
20:04:50 4 SMTP(tcp) Connection accepted from [***.***.***.***:*****], seq=1, 1/2
20:04:50 4 SMTP-002([***.***.***.***:*****]) Sending 220-Stalker Internet Mail Server V.1.8b8 is ready.\r\n220 ESMTP is spoken here. You are welcome\r\n
20:04:50 5 SMTP-002([***.***.***.***:*****]) OT 95 of 95 bytes sent, Flags=0
20:04:50 5 SMTP-002([***.***.***.***:*****]) *Status=22
20:09:50 3 SMTP-002([***.***.***.***:*****]) Time-Out. Read: 
20:09:50 5 SMTP-002([***.***.***.***:*****]) *Status=3
20:09:50 4 SMTP-002([***.***.***.***:*****]) Aborting
20:09:50 5 SMTP-002([***.***.***.***:*****]) *Status=2
20:09:50 5 SMTP-002([***.***.***.***:*****]) Disconnect Completed

たまちゃん さんからのコメント
( Tuesday, August 22, 2000 00:28:39 )

SMTP Service Settings の Receiving Options で TCP/IP Channels がゼロで
はないとします。

同様のエラーに遭遇した SIMS のユーザさんもいます。彼(?)の場合は,
1.7 では起こらないが,1.8 にした途端に外部からメールを受信出来なく
なったそうです。

原因は不明です。対処方法もしたがって分かりません。

SIMS ではこのような(原因不明の)ことが起こることがあります。

さんからのコメント
( Tuesday, August 22, 2000 12:12:24 )

うちも突然、外部からのメールのみ受け付けないようになりました。
外部への送信と内部通しの送信、およびWWW,FTPなどはできるのに
外部からの受信のみが通過できないという事がありました。

何度かあったのですが、あるマシンではOpenTransport,SIMS,TCP/IP pref
を捨てて直りましたが、結局はよくわからないままでした。

またある時は、IPNetRouterの設定の中でExposed Hostというのがありますが
あれをgateway以外にしておくとメールの受信のみを拒否するといった事が
ありました。

芝田さんの状況はわかりませんが、研究室の上流のサーバーは何でしょうか?

どこまで確かか定かではありませんが・・・
もしも上流のサーバーがSUNを使っていた場合、Linuxやその他のUNIX系OS
とは若干Pingの型式が異なるらしく、Pingを打った回数がまともに帰って
こない仕様になっており、見えないと見なされて配送を延期されてしまう
場合があるそうです。

こちらの場合、別のサーバーからPingを打ってもらって確認していたら、
突然上流のサーバーに繋がるようになった、なんてことがありました。

芝田さんのサーバーがどのような構成になっているか分かりませんが、
あとはSIMSだけを疑うのではなく、NIC(ドライバ)にも疑いを持ってみては?
上のケースとは別ですけど、そういう場合もありました・・・・

あとトラブル内容は異なりますが、SIMSのMLではトラブルが起きた時に
DiskWarriorやNortonをかけたり機能拡張を基本構成に戻したり、仮想メモリ
をきることで復帰できた、なんてことも書かれてました。
こうなるとMacOSやハードの問題になっちゃうのかな!?