このページは福井県立大学の田中求之が2006年1月まで運用していた Mac のサーバ運用に関する会議室 「Web Scripter's Meeting」の記録です。情報が古くなっている可能性がありますのでご注意ください。

ASIPメールサーバ起動時の問題

発言者:人類
( Date Wednesday, June 21, 2000 12:44:31 )


以前、大学の研究室で運営しているASIPメールサーバを起動すると直後に不正終了してしまう問題についてご相談させていただき、しあわせのツボさんからDNSのAレコードと逆引きPTR設定が間違っている可能性があるというご指摘をいただきました。

そこで学内LANのDNS管理者に問い合わせたところ、「SPAM対策のため、学外から学内のすべてのメールサーバ宛に送信されたメールを、一旦SPAM対策の施された特定のメールサーバに送るようDNSのMX情報を設定してある」とのことでした。

試しにメールサーバとして管理者に届けを出していない、つまり上記のようなMX情報の設定がなされていないマシンでASIPメールサーバを起動したところ、正常に起動しました。

しかし、メールサーバとして届けを出しているマシンでメールサーバを運営したいのです。何か方法はないでしょうか。みなさまの知恵をお借りしたく存じます。

田中求之 さんからのコメント
( Wednesday, June 21, 2000 13:13:31 )

>DNSのAレコードと逆引きPTR設定が間違っている可能性

この問題と MX レコードの設定は関係ないと思うのですが…?? ホスト名
の A レコードと、逆引の IP が一致していない可能性があるという問題は
解決されたのでしょうか?

…MX レコードの設定次第で起動しなくなることがあるのかなぁ??


もっとも、ASIP に関しては、公開されている情報が少ないので、なにが
どうなっているのか分からない部分が多いですけど。

しあわせのツボ さんからのコメント
( Wednesday, June 21, 2000 14:07:03 )

私も不思議に思います。(苦笑)

うちでは、ASIPメールサーバが自身について逆引をした時に
・何も返ってこない
   >そのままIPアドレスでメールサーバ起動
・自身のカノニカル名とMXレコードが正しく返ってくる
   >ドメイン名およびホスト名を受け付け普通に起動
・それ以外(自身のCNAME値しか返ってこない等)
   >起動できない(エラーが出て異常終了)
という動作をします。

もし可能でしたら、「本来認証されているマシン」のIPを
未認証のIPに変えて、マシンを再起動してみて下さい。
それで動作するようなら、DNSとの間に何かあると思います。

人類 さんからのコメント
( Wednesday, June 21, 2000 14:56:35 )

田中さん、しあわせのツボさん、コメントありがとうございます。

>もし可能でしたら、「本来認証されているマシン」のIPを
>未認証のIPに変えて、マシンを再起動してみて下さい。
>それで動作するようなら、DNSとの間に何かあると思います。

未認証のIPをいくつか試してみましたが、いずれも動作します。隣の部署でもASIPサーバが同じトラブルに見舞われており、こちらもメールサーバとして届けているIPで起動した場合のみ終了しています。


学内のSPAM対策についてもう少し説明しますと、

 ・登録されている学内のメールサーバ(仮にasip.univ.ac.jp)のMXレコードはセキュリティ用メールサーバ(sms.univ.ac.jp:OS=FreeBSD)に設定されている。これにより登録MS宛に来たメールはすべて一旦sms.univ.ac.jpに送られる。
 ・sms.univ.ac.jpは送られたメールが外部からか内部からかを判定し、SMTP接続が外部からの場合には受信者のアドレスが登録MSの場合のみ該当するMSに転送を行う。

というようになっています。うちの部署の登録MSのAレコードと逆引きPTRは正しく設定されており、あと考えられるのはこのMXレコードの設定だけなのです。

このようなDNS設定ではASIPメールサーバは使えないということでしょうか。ASIPはFile&Webサーバとして動かして、メールサーバはSIMSに乗り換えた方がいいのかな。

田中求之 さんからのコメント
( Wednesday, June 21, 2000 19:38:40 )

人類さんの状況(設定)は、うちの大学の場合も同じです。

…で、これまで私が G3 で運用している ASIP でメールサーバが起動できない
でいたのですが、もしかしたら、原因は MX レコードだったのかと思い始めました。

私のところでも、ホスト名は A レコードで登録してあり、逆引も正しく
設定されたマシン( G3 MT )で ASIP を動かしているのですが、このホスト
(サーバ)の MX は、大学のメールサーバが Preference 10 で指定され、
このマシン自体を直接には指定していません。大学のメールサーバ経由で
転送されてくることになるわけです。

で、色々な発言の中ですでに書いたのですが、どうしてもメールサーバ
だけが起動しない(起動しようとするとフリーズしてしまう)わけです。
ASIP 6.2 からのアップデート版であることが原因かなと思っていたので
すが、MX レコードの問題なのかもしれません。

でも、もし MX が原因で起動できないとしたら、人類さんや私のように、
ファイアーウォールの内側で運用しようとしているメールサーバには
使えないということになりますよね。これでは、このご時世、使い物に
ならへんでぇ…

ASIP の ML の MX に関する話題は、これまで無関係だと思って読み飛ばして
きたんですが、ちょっと注意して探ってみたいと思います。

Apple の Tech Exchange (でしたっけ? Apple のサイトの会議室ですが)
では、このことは話題になっていないのかな?? (あの会議室は使い勝手が
悪いので、のぞく気にならないのですが)

人類 さんからのコメント
( Wednesday, June 21, 2000 21:13:19 )

>でも、もし MX が原因で起動できないとしたら、人類さんや私のように、
>ファイアーウォールの内側で運用しようとしているメールサーバには
>使えないということになりますよね。これでは、このご時世、使い物に
>ならへんでぇ…

本当に使い物にならないです。何か方策はないものでしょうか。
ルータを介して学内LANに接続するようにしてもだめでしょうか。