このページは福井県立大学の田中求之が2006年1月まで運用していた Mac のサーバ運用に関する会議室 「Web Scripter's Meeting」の記録です。情報が古くなっている可能性がありますのでご注意ください。

ASIP でのメールサーバー設定

発言者:齋藤
( Date Thursday, June 15, 2000 12:19:46 )


ASIP 超初心者です。ASIP でサーバーをたてようとしていますがメール
サーバー設定で行き詰まってしまいました。どなたか設定を教えて下さい。

環境

ルーター:MN128-SOHO SL10 (v.2.3)

サーバー
PM7600 (+Sonnet G3).....ASIP 6.3.1 + Quick DNS Pro 2.2.1J (以下QDP)
 (DNS、WWW、Mail)
G4 (400).....FMPro

クライアントその他3台

5台のLANのうち2台を MN128 のNAT設定でWANに公開しています。
DNS、WWW は正常に稼働しています。

状況
1)メールサーバ起動時にエラーが出ます。
 ログ(192.168.0.21はサーバーのローカルアドレスです)
  ### 設定の確認:“192.168.0.21”で受信したすべてのメールはローカルの
  配送として扱います。
  ### 警告 ###  リバース IP 名のルックアップ中に 1 TCP/IP-DNS エラーが
  起きました。
2)クライアントからメールの送受信をしようとするとサーバーに接続されません
 エラーメッセージ
  接続に失敗しました。 送受信の操作を再度行い、接続できない場合は、接続
  の設定を確認してください。(Error: -23016)
 ログ
  POP3 利用者は TCP/IP を使ってサーバ“mail.xxxxx.co.jp:110”に接続しよう
  としています(POP3 アカウント:aaa@xxxxx.co.jp)。
  POP3 利用者は TCP/IP を使ったサーバ“mail.xxxxx.co.jp:110”への接続に
  失敗しました(POP3 アカウント:aaa@mail.xxxxx.co.jp)。

・ヘルプ、AppleShareIP 実践ガイドブック、TIL、本サイトなどを参考に設定はして
 あるつもりです。
・メールサーバーは QDP のCNAME で mail.xxxxx.co.jp として登録してあります。

チェックすべきポイントなど思い当たる点があればよろしくお願いします。

齋藤 さんからのコメント
( Friday, June 16, 2000 15:06:46 )

自己レスです。

TIL の
http://til.info.apple.co.jp/cgi-bin/WebObjects/TechInfo.woa/wa/showTIL?id=24693

http://til.info.apple.co.jp/cgi-bin/WebObjects/TechInfo.woa/wa/showTIL?id=24962

を見る限り、グローバル用の外向けDNSとローカル用の内向けDNSが必要
のようですが、違ってますでしょうか? その場合、Quick DNS(WAN用)
とMac DNS(LAN用)を1台のマシンで併用しても大丈夫なものでしょうか。

本フォーラムの過去の記事を再度検索してみましたが、似たような問題に
結局解決法が無かったようです。

このフォーラムをご覧の方で、ルータの NAT 機能を利用して LAN 内に
メールサーバーを設置されている方、特に問題はないのでしょうか?

しあわせのツボ さんからのコメント
( Friday, June 16, 2000 16:27:35 )

http://til.info.apple.co.jp/cgi-bin/WebObjects/TechInfo.woa/wa/showTIL?id=24568
ここの19-IIを流用すれば内向けDNSは不要になるかと思います(試していません)。
# うまくいったとしても起動時のエラーメッセージは消えませんが。

うちもMN128-SOHO SL11のNAT下にメールサーバを立てていますが、
とりあえず内向けDNSを立てています。

齋藤 さんからのコメント
( Friday, June 16, 2000 17:55:11 )

しあわせのツボ さん ありがとうございます。

http://til.info.apple.co.jp/cgi-bin/WebObjects/TechInfo.woa/wa/showTIL?id=24962

を再読して設定をし直したら何とか開通しました。

http://til.info.apple.co.jp/cgi-bin/WebObjects/TechInfo.woa/wa/showTIL?id=24568

ともほぼ同様の手順でした。

お騒がせしました。