このページは福井県立大学の田中求之が2006年1月まで運用していた Mac のサーバ運用に関する会議室 「Web Scripter's Meeting」の記録です。情報が古くなっている可能性がありますのでご注意ください。

QuickDNSの設定について

発言者:きよし
( Date Saturday, June 10, 2000 01:24:22 )


今まで気にはならなかったのですが i-mode用のHPを立ち上げたときに気に
なった事が有ります。
i-modeからwww2(***.9.2.10)に接続をすると一度www2サーバに接続された素振りをして
画面が一度チカッとして また接続をしに行きます。そして約1秒後に接続されます。
これはドメイン名での接続でもIPアドレスでの接続でもこの症状が出ます。
最初は自分が作ったHPの作り方が悪いのかi-modeのせいかと思っていました。
しかしQuickDNSに登録していないテスト用のwebServer(したがってI-modeから
IPアドレス(***.9.2.11)での直接的な呼び出し)は問題有りませんでした。
そこで思ったのは 根本的にQuickDNSの設定が間違っているのでは???

QuickDNS Pro Adminを立ち上げて 出ている画面を書きます。


ウインドウのプライマリードメイン
ヲ test-jp.com.
ヲ 2.9.***.in-addr.arpa.

ウインドウのセカンダリ データ
なにも設定されていません。

-------test-jp.com.-------
ホスト名       TTL  タイプ   パラメータ1
test-jp.com.             NS          ns.test-jp.com.
test-jp.com.             NS          ns3.allnet.ne.jp.
test-jp.com.             HINFO       Macintosh
test-jp.com.             MX          10
ns.test-jp.com.          A           ***.9.2.9
www.test-jp.com.         CNAME       ns.test-jp.com.
mail.test-jp.com.        CNAME       ns.test-jp.com.
www2.test-jp.com.        A           ***.9.2.10


-------2.9.***.in-addr.arpa.-------
ホスト名       TTL  タイプ   パラメータ1
2.9.***.in-addr.arpa.        NS          ns.test-jp.com.
2.9.***.in-addr.arpa.        NS          ns3.allnet.ne.jp.
9.2.9.***.in-addr.arpa.      PTR         ns.test-jp.com.
10.2.9.***.in-addr.arpa.     PTR         www2.test-
                                           ↑ここをダブルクリックすると
                     www2.test-jp.com.が出ます。

問題箇所をご指導下さい。

田中求之 さんからのコメント
( Saturday, June 10, 2000 02:54:14 )

iMode のことはわかりませんが…

>これはドメイン名での接続でもIPアドレスでの接続でもこの症状が出ます。

IP アドレスによる接続の場合には、DNS は関係ないはずです。ですから、
DNS の設定が問題とは考えられないのですが…

今井真人 さんからのコメント
( Saturday, June 10, 2000 07:35:43 )

 IPNetMonitorなど、検査ツールで名前引きの検査などは一通りやって
みてますか?

今井真人 さんからのコメント
( Saturday, June 10, 2000 07:42:29 )

> test-jp.com.             HINFO       Macintosh

最近の傾向で言えば、このレコードは必要ないです。余分な情報は外部に
漏らさないのが基本だと思っています。

きよし さんからのコメント
( Saturday, June 10, 2000 15:50:19 )

田中さん、今井さん ありがとうございます。
田中さんの言うようにDNSは関係有りませんでした。
ファイルメーカーProでWebを公開しているのですが
1台のマシーン(接続の時にちょっとおかしな動作をする方)は
ファイルメーカーPro 4.0v3です。もう一台テストしたマシーン
(問題が起きない)はアップデートしていないファイルメーカーPro 4.0v1でした。
v1からv2に変わるときWeb コンパニオンがマイナーバージョンアップしました。
(Web使用者数が増加した状況が続くと、WebコンパニオンがWeb上でのデータ
ベース共有を止めてしまう問題。)
Web コンパニオンだけを入れ替えてチェックしたら 問題はそこでした。
ファイルメーカーPro 4.1を使用しているがいましたらWeb コンパニオンの
バージョンを教えて下さい。
ちなみにファイルメーカーPro 4.0v3のWeb コンパニオンは
作成日 1988.10.17  修正日 1998.10.21
バージョンは Web コンパニオン 4.0v2 です。

しあわせのツボ さんからのコメント
( Monday, June 12, 2000 11:42:21 )

4.1v2でもWebコンパニオンのバージョンは4.0v2でした。
ただし作成日・修正日が1998.9.8になっています。

きよし さんからのコメント
( Monday, June 12, 2000 15:46:48 )

しあわせのツボさん ありがとうございます。

> 4.1v2でもWebコンパニオンのバージョンは4.0v2でした。
> ただし作成日・修正日が1998.9.8になっています。

ってことは きっと変わらないですね。
今度ファイルメーカー5.0で試してみます。
でも 5.0にすると最終的にはUnlimitedを買わないとWeb公開
できないし・・・

きよし さんからのコメント
( Monday, June 12, 2000 16:13:28 )

自己レスです。
ファイルメーカーpro5.0v3
Webコンパニオンv4でも同じでした。
不都合は無いのですが 一度接続されて一瞬で切れて1〜2秒後にまた接続される。
ちょっとイヤです。