このページは福井県立大学の田中求之が2006年1月まで運用していた Mac のサーバ運用に関する会議室 「Web Scripter's Meeting」の記録です。情報が古くなっている可能性がありますのでご注意ください。

画像が壊れてしまいます。

発言者:日高尚人
( Date Thursday, July 16, 1998 15:27:43 )


ご無沙汰してます。
ポートベロの日高です。

現在WebSTAR2.0Jでサーバーを運用しています。
そこに上げているホームページについてなんですが、
以下のような現象がおきてしまうのです。

----------------------------------------------------------------

トップページのリンクボタンを経由すると、問題なく表示されるのですが、
そのページのURLへ直接とぶと、画像が全て壊れてしまいます。

-----------------------------------------------------------------

同じような経験をされた方、考えられる点がありましたらご教授
願えないでしょうか。よろしくお願いします。








田中求之 さんからのコメント
( Thursday, July 16, 1998 16:11:08 )

ブラウザのキャッシュをクリアする(あるいは強制再読み込みを行う)ても症状は
改善されませんか?

また、サーバーのキャッシュの設定、および Plugin の状況はどうなっていますか?

日高 さんからのコメント
( Thursday, July 16, 1998 17:02:37 )

田中さん、早速のレスありがとうございます。
 社内のどのマシンからアクセスしてもダメなので、ブラウザのキャッシュの
問題ではないと思います。ためしにキャッシュをクリアしてみましたが、
やはりだめでした。
サーバーのキャッシュへは、70MB割り当てています。
また、pluginは以下のものが入っています。

Welcome-Plugin1.5 E
WebSTAR SSI1.0.4
WebSTAR QuickSend1.0.1
WebSTAR Log Roller1.0
WebSTAR Java VM1.0.1
WebSTAR Image Map1.0
WebSTAR File Upload1.0.1
WebSTAR Directory Indexer1.0
WebSTAR Data Cache1.0.3
WebSTAR Byte Server1.0.1
WebSTAR Auto BinHex1.0
WebSTAR Admin1.0.1
COUNTWWWEBULA-PLUGIN

よろしくお願いします。


田中求之 さんからのコメント
( Thursday, July 16, 1998 17:42:50 )

すごい数の Plugin を入れてますね。これ全部使ってますか?

それhさておき、サーバーの KeepAlive 接続を有効にしてますか? もし有効に
してあるなら、これを無効( KeepAlive 接続の接続数を 0 にする)。

それと、サーバー側のキャッシュをクリア(データキャッシュをクリアするには
2.1 ではサーバーをリスタートするしかなかったと思いますが)してみてください。
(しかし 70M とはすごい量を割り当ててますね)

日高 さんからのコメント
( Thursday, July 16, 1998 19:40:12 )

サーバーをリスタートしたら、無事表示されました。
どうもありがとうございました。

また、何か不可解な現象がおきたら助けて下さい。