このページは福井県立大学の田中求之が2006年1月まで運用していた Mac のサーバ運用に関する会議室 「Web Scripter's Meeting」の記録です。情報が古くなっている可能性がありますのでご注意ください。

HDがずっとアクセスする

発言者:峯 啓真
( Date Saturday, June 06, 1998 22:00:07 )


WebSTAR3.0にてWebサーバーを立ちあげて、1週間ほどたちました。途中
1度フリーズしていた事がありましたが、たいしたトラブルも無く順調です。
所が、いつの頃か、サーバーのHDがどこからのアクセスも無いのに
つねに「カリカリ」と音を出して、読み書きをしている、ようなんです。
これで、正常ならば、別に良いのですが、何となく不安です。また
WebSTAR3.0の画面には

***Men: 2318906

といったように何やらランダムな数字がつらつらと周期的に続きます。
恐らくこの数値はメモリの量の事だと思うのですが、問題はないので
しょうか?サーバーには、WebSTARの他にQuick DNS Pro、SIMSが
稼動してます。

田中求之 さんからのコメント
( Sunday, June 07, 1998 00:31:58 )

WebSTAR の Plugin はどんなものを入れてますか?

>何やらランダムな数字がつらつらと周期的に続きます。

これは初めて聞く現象ですねぇ。

峯 啓真 さんからのコメント
( Sunday, June 07, 1998 06:01:08 )

プラグインは、標準のままです。であれから解った事は取り敢えずWebSTARを
終了するとアクセスは止まります。メモリの割り当てを増やしたりしてみま
したが、事態は変りません。やはり変なのでしょうか?

取り敢えず、使わないプラグインは極力外して試してみます。


峯 啓真 さんからのコメント
( Sunday, June 07, 1998 07:08:31 )

総べてのプラグインを外して試した所、現象は止まりました。そこで一つ一つ
必要な物を戻して再起動していった所、どうやらプロキシを入れていると
発生する事が解りました。取り敢えず今は、外して様子を見ます。

田中求之 さんからのコメント
( Sunday, June 07, 1998 14:17:44 )

Proxy が必要だったのでしょうか?

>プラグインは、標準のままです

プラグインに「標準」はないです。「インストールしたまま」ということでしたら
それは「余分なものが入りすぎて非常に危険な状態」を意味しています。

WebSTAR 3.0 を動かすのに「最低限必要な」 Plugin は、実は一つもありません。
何も Plugin を入れないのが、一番確実です。ただ、これでは Admin が動かせ
ませんので、Admin が使えるようにするために、Admin と SSI を入れる必要が
ありますので、強いて言うなら、これが「最低限」ですね。

その他の Plugin は、「その機能が必要で、動かせる資源もある」ということなら入れる
ものです。ただし、Java 関連のように、入れてしまったことでトラブルが出るものが
ありますので、その点はご自分で確認してください。

峯 啓真 さんからのコメント
( Sunday, June 07, 1998 17:53:13 )

>プラグインに「標準」はないです。「インストールしたまま」ということでしたら
>それは「余分なものが入りすぎて非常に危険な状態」を意味しています。

うむむ、そうなんですか、どのプラグインがどんな役割を持っているか
不明な部分がありましたので、外すに外せませんでした。現在は大分解って
きたので、AdminとSSIの他、FTPとFile Upload、データキャッシュ、バーチャル
ホスト、AutoBinHex(ひっとしてこれも要らないのかも)だけにしてみました。
今の所は、落ち着いてやれやれです。

プラグインの機能と役割を紹介しページとかないかなァ(まぁマニュアルを
読めば良いのでしょうけど)

田中求之 さんからのコメント
( Sunday, June 07, 1998 19:44:08 )

>プラグインの機能と役割を紹介しページとかないかなァ

簡単にまとめたものを、後ほど「WebSTAR 3.0 の運用」の発言の方に書き込んでおきます。

峯 啓真 さんからのコメント
( Sunday, June 07, 1998 22:01:42 )

>単にまとめたものを、後ほど「WebSTAR 3.0 の運用」の発言の方に書き込んでおきます。

助かります。早速、覗いてみます

きしもと さんからのコメント
( Monday, June 08, 1998 04:55:04 )

便乗発言で恐縮ですが、
EIMS1.xを使っているときもHDが常にカリカリ(カッカ?)いうことないですか?
いままでは、こんな事もあるのか、と少々不安ながらも詳しくは調べていなかったのですが。
峯さんのProxyの事も含め、結局何が原因なんでしょうか・・・

田中求之 さんからのコメント
( Monday, June 08, 1998 19:33:45 )

EIMS だけしか動かしていませんか?

スプールのチェックのためにハードディスクにアクセスすることは考えられますが。

きしもと さんからのコメント
( Thursday, June 11, 1998 16:49:57 )

> EIMS だけしか動かしていませんか?
そうです(というかそういう環境でも試した)。終了させると音も止まるんです。

> スプールのチェックのためにハードディスクにアクセスすることは考えられますが。
そうですね。
けどEIMSって、カッカと音が聞こえる時の頻度で(1秒に1回くらい)
そんなにずっとアクセスしているものなのでしょうか?

よーすけ さんからのコメント
( Thursday, June 11, 1998 22:34:28 )

>カッカと音が聞こえる時の頻度で(1秒に1回くらい)

KT7.5.Xで機能拡張フォルダーに「デスクトップ・プリントモニタ」と「Desktop Printer Spooler」が
入っていると、上記とまったく同じ症状がでますが、KT8になって改善されました。
アプリケーションの立ち上げの有無にかかわらず、HDがちょうど1秒間隔でカリッ、カリッといいます。
でも、これって関係ないですよね。的はずれだったらごめんなさい。

きしもと さんからのコメント
( Monday, June 15, 1998 08:17:55 )

ああ、そうかもしれません。
>アプリケーションの立ち上げの有無にかかわらず
ここがひっかるところですけど、
確かにOS8にしてからなくなったような気がします。
今回のproxyの問題もよーすけさんが指摘されたことと関係があって、
問題が改善されきっていないだけなのでしょうか?