このページは福井県立大学の田中求之が2006年1月まで運用していた Mac のサーバ運用に関する会議室 「Web Scripter's Meeting」の記録です。情報が古くなっている可能性がありますのでご注意ください。

PHSで会社のARAサーバーに接続

発言者:平野良明
( Date Friday, March 06, 1998 21:54:11 )


どなたか教えて下さい。PHSを使って外から会社に接続をしたいんですが
うまくいきません。ARA3.0を使って接続をしたいのですがどこが、何が
悪いのかわからないので固まってしまいました。

現在の環境は、
PB2400+PHS → NEC Aterm65Pro/DSU → ARAサーバー(PPC) → <Ether> →
hub → <Ether> → DNS&WWWサーバー(PPC) → <Ether> → MN-128/SOHO → OCN

自宅から、ISDN経由で繋ぐと上記の環境でうまく作動します。
Aterm65Pro/DSUのファームもバージョンをあげてPIAFS対応にはしているんですが
繋がりません。というよりも、正確にいうと繋がってはいるのですが、
プロトコルの確立ができないようです。着信の認識(Aterm)はしていますが
暫くすると切断してしまいます。
何か良い解決策を教えて下さい。

清 秀紀 さんからのコメント
( Saturday, March 07, 1998 10:17:58 )

ARAは、すんなり行く環境のときはうまく行って快適ですが、うまく
行かないときはその理由もよくわからず、往生します ;)

使用プロトコルは [自動]、[PPP] [ARAP] の3つがありますが、なん
となく [自動] はよくなさそうな気がしています。あとの2つを別の
条件 (CCLファイルの選択など) と組み合わせて試してみてはいかが
でしょう。

平野良明 さんからのコメント
( Tuesday, March 10, 1998 13:11:17 )

コメントありがとうございます。
再度、いろいろな条件で接続をしてみましたが、できません。

>>うまく行かないときはその理由もよくわからず、往生します
とても往生しています。
せめて、理由だけも分かれば対処できるかも知れないのですが・・・


清 秀紀 さんからのコメント
( Tuesday, March 10, 1998 15:23:00 )

[オプション] ボタンの [接続] タブで [詳しい情報も記録する] を
チェックすると、ほんの少しだけ詳しいログが残るようになりま
す。[リモートアクセス] - [作業記録] でログを表示したり、書き
出したり、消去したりできます。

もしまだ試されていませんでしたら、そのログを見ると、少しだけ
状況が明らかになるかもしれません。

当方では [搬送波が検出できません] というエラーに最も悩まされ
ました。「理由がわからないのや説明するのが面倒くさいのは全部
このエラーにしてんじゃないの?」って風に思っていたりします ;)

田中圭二 さんからのコメント
( Wednesday, March 11, 1998 00:56:48 )

私も苦労しました。私の場合は、
PHS--AtermIT65--PM7200(DNS,AIMS,WebSter,ARA3.0)--MN128SOHO--OCN
という構成です。何でもPM7200に詰め込んでいるのでそれが悪いの
かと思いましたが。結果、CCLファイルが原因でした。
で、自己流ですが、モデムスクリプトジェネレーターで作ってみたところ
うまく行きました。
init string   q0v1x3$n1=2&d1
speed  57.6k
speed 115.2k
他は何も設定しないで作ったところ、うまくできました。
クライアント側はリモートのみで PPP
サーバー側はイーサネットで ppp
以上の設定で、現在うまく動いています。PHSへのコールバックも成功しました。
もっと他にいい方法があるかもしれませんが、参考までに。

田中圭二 さんからのコメント
( Wednesday, March 11, 1998 01:16:10 )

補足
上のモデムスクリプトは、たまたま一発でうまくいってしまったので
ほかの設定で試してみたわけではありませんのでこれが最良の方法かは
わかりません。だた、デフォルトの状態ではPIAFSの着信を受けないよう
になっているのだと思います。ですから=2でPIAFSの着信を受け付けるような
設定になります。
私は、まだ試していませんが、この設定をすると次の通信がPIAFS以外の場合は
また設定を変更しなければならないというようなことが設定マニュアルの
p163に書いてあります。

平野良明 さんからのコメント
( Wednesday, March 11, 1998 22:28:44 )

貴重なアドバイスありがとうございます。

CCLファイルを作ったら接続ができました。感激で涙涙です。
本当にありがとうございました。

Aterm自体は対応でもCCLがPIAFS対応でなかったのですね、
それと
>>次の通信がPIAFS以外の場合はまた設定を変更しなければならない
に関してですが、そのようですね (^^;
とりあえずその問題は先送りにしました。

接続できて胸のつかえがとれました。
今日からゆっくり眠れます。本当にありがとうございました。

田中圭二 さんからのコメント
( Thursday, March 12, 1998 09:56:22 )

いつも、ここにはお世話になっているので、お役に立てて光栄です。

田中圭二 さんからのコメント
( Thursday, March 12, 1998 22:26:45 )

つい先ほど、友人のTAを使用して、Atermに接続できました。
CCLファイルはそのままで、TAとPIAFSが使用できます。

平野良明 さんからのコメント
( Friday, March 20, 1998 10:26:04 )

田中さんありがとうございます。
別の仕事が忙しくMacに時間を使えなかったので
TAからの実験がまだできていないのですが
大丈夫ということで安心しました。

時間を見つけて実験してみます。

清 秀紀 さんからのコメント
( Friday, March 20, 1998 14:09:34 )

ちょっと疑問なのですが、ARAサーバーって受信時もCCLファイルで
モデムやTAをイニシャライズしたりしますか?

というのが、CCLをポップアップリストから変更したとして、その変
更をARAサーバーがモデムやTAに送っているようには見えないのです
よね。

ですから、受信にCCLは一切関係ないと思っていました。

田中圭二 さんからのコメント
( Sunday, March 22, 1998 05:43:29 )

今、クライアントを使ってこれを書いているので、確かなことは言えませんが、
何かうまく繋がる方法はないかと色々試していて、CCLを色々他社のものも
含めて換えてみた時に、ポップアップリストで変更して、ウィンドウを閉じると
しばらくして、モデムが正常に応答しません、使用している機種を確認して
CCLを選びなおしてくださいというアラートがでたと思います。
TAを使って送受信をする前にこれが出たので、変更したときにはTAにコマンドを
送っているようです。
その後、気が付かないで一時的にTAの電源だけを抜いてしまって、クライアントでアクセスできなく
なったときがありましたので、送受信の度にイニシャライズしているのではないようです。
クライアントではこのアラートは、出ませんでした。

清 秀紀 さんからのコメント
( Sunday, March 22, 1998 08:58:47 )

うーん、私の勘違いかもしれません。

念のため、先の投稿の前にARA PS 3.0で試してはみたのですが。

CCLを変更したときに、TA/モデムにコマンドを送信するときと、
しないときとがあるような気がします。

今度、機会があったら調べてみます。