このページは福井県立大学の田中求之が2006年1月まで運用していた Mac のサーバ運用に関する会議室 「Web Scripter's Meeting」の記録です。情報が古くなっている可能性がありますのでご注意ください。

acgiでタイプ1エラー?

発言者:まつむら
( Date Thursday, June 19, 1997 12:09:43 )


 MacサーバによるSOHO構築に関する貴重な情報、いつもROMばかりですが、
たいへん参考にさせていただいてます。

 田中先生のbooklistをベースに、会社のイントラで簡単なデータベース検索
サービスを行っています。レコード数は約50件。文字のみのデータです。
データの更新は、ローカルでやっており、サービスは件名一覧表示と、詳細表
示の検索機能のみです。
 サーバはperforma588で、QPQとFMPro2を入れて半年以上動いています。
スピードはともかく、特にトラブルはなく順調でした。(その間、AIMSも同居
していましたが、最近外しました。)

 さて、トラブル内容ですが、一覧もしくは、タイトルからの検索結果にもと
づき、特定のレコードを詳細表示させようとしますと、
acgiが「タイプ1のエラーが発生しました」というメッセージとともに停止
してしまうのです。
 当初は、データ内に特殊なコードでも入ったのではないかと疑ったりして、
そのチェックや、OSを再インストールしてみたり、別のP588に移してみたり、
」acgiのコンパイのやり直しやQPQを最新版に入れ替えてみたりといろいろ
切り分けをしてみたのですが、まったく改善しませんでした。メモリーは48MB
積んで、それぞれたっぷり割り当てているので不足はないと思います。
 ところが、全く同じものがPoweMac(PM8100やP6210)上では何の問題も
なく動くと言うこともわかり、途方に暮れています。

 エラーメッセージのとおり、どうも、システム上の問題ではないかと思うの
ですが、何をどうしたらいいのか見当がつきません。こちらでお尋ねする内容
ではないのかもしれませんが、何かヒントをいただければと思いまして。。

田中求之 さんからのコメント
( Thursday, June 19, 1997 20:19:14 )

システムかファイルメーカーの問題だと思いますが、ちょっと見当がつかない
ですねぇ。

CGI には十分にメモリーを割り当てて動かしてますか? それとシステムの
バージョンとファイルメーカーのバージョンはいくつのものをお使いでしょうか?

まつむら さんからのコメント
( Monday, June 23, 1997 16:43:05 )

CGIには最低でも2MB以上のメモリーを割り当ててあります。
ぜいたくに4MB〜8MB割り当てても同じでした。
システムは、MacOS 7.5.1と7.5.3の両方で試してみました。
ファイルメーカーのバージョンは2.1v2(メモリ割当8MB)
データのサイズは250KB程度。
QuidProQuoは1.0.1(メモリ割当8MB)です。

CGIに起因するものではないと思いつつも、ポストしてしまいまして、
ご迷惑おかけいたします。何か心当たりあればで結構です。
だめでも、しばらくPowerMacでしのげますし、
実は、WinNT+OracleWebServerへの移行はもともと計画中ですので、
それを早めるようにします。
(しかし、私はこじんまりとしたSOHOが好きなんですけど・・)

それにしても、こうした複合的なエラーはどこへ話を持ち込めばいいのか
ほんとに悩みますねぇ(^^;)

田中求之 さんからのコメント
( Tuesday, June 24, 1997 01:07:02 )

問題のレコードに、AppleScript で( CGI ではなく、普通のスクリプトで)アクセス
した場合には、なんら問題は起きないのですね?

いずれのせよ、特定の機種(というか 68K マック)だけで問題が起きるとなると、
やっかいであることは確かですね。