このページは福井県立大学の田中求之が2006年1月まで運用していた Mac のサーバ運用に関する会議室 「Web Scripter's Meeting」の記録です。情報が古くなっている可能性がありますのでご注意ください。

sendMail(2.0) -> AIMS の相性????

発言者:mazda
( Date Monday, September 16, 1996 12:08:30 )


いつも参考にさせていただいています
さてちょっと質問なのですが、田中先生のお作りになったMailerSmapleの
sendMail(2.0)を使用してAIMSから外部に向けてメール送信しているのですが
4〜5回メール送信をするとAIMSがsendMail(2.0)で反応しなくなってしまいます
その状態で別のクライアントからメールの送信や受信等はAIMS動作します
なぜなのでしょうか?、もちろんAIMSを再起動すればなおりますが...

環境としては7600/120のOTで、同時にQuickDNSProが動作しています
TCP/IP Scripting Addition Osaxはまだ登録処理はしていません

よろしくお願いします。

田中求之 さんからのコメント
( Tuesday, September 17, 1996 18:33:12 )

私のところではこの現象は起きていません。

repeat を使って10回連続送信を行うテストをやってみましたが、すべて問題なく
処理されます(ただし、AIMS とスクリプトを同じマシンで動かすと遅いです。やはり
メールはメールサーバーを確保するのが確実ですねぇ)。

PM 8100/100 + 7.5.3 + OT1.1.1b7 という環境です。TCP/IP osax は 2.0.7
です。

mazda さんからのコメント
( Wednesday, September 18, 1996 14:23:40 )

そうですか、ただし連続10回ならこっちでもOKの時があるのですが
後は、メールサーバーの設定でしょうか?
1つおかしい点としては、DNSと同じマシーンで動作させているのか
DNSの設定がおかしいのかはわかりませんが、AIMSを起動させた時に
DNSからドメイン名をひっぱってこなく、NO NAMEという表示で起動してしまいます
設定でなんとか動作しているので、いまの所ほったからしてはいるのですが気になる点です
動作しなくなる現象としては、詳しいことはわからないのですがCGIがAIMSに対して
接続をちゃんと切っているのに、AIMSは切れていない様な感じもします

田中求之 さんからのコメント
( Wednesday, September 18, 1996 18:12:14 )

>後は、メールサーバーの設定でしょうか?

といっても、AIMS の設定で関係しそうなものは見あたりませんよね?

OpenTransport はバージョンいくつですか? OT の問題の可能性も
考えられ無くはないですね。


石津@RJC さんからのコメント
( Wednesday, September 18, 1996 20:43:02 )

うちの環境で実験した際にAIMS1.1をOpenTransport1.1Jで動作させると
SMTPやPOP3のセッションが時々利用できなくなるということがしばしば
ありました。

そのためAIMSはMacTCPで動作させています。
取り敢えずこれで問題は発生しなくなりました。

mazda さんからのコメント
( Thursday, September 19, 1996 00:55:39 )

>そのためAIMSはMacTCPで動作させています。
>取り敢えずこれで問題は発生しなくなりました。

ありがとうございました、AIMSをMacTCPで走らせたら
問題は発生しなくなりました、どうやら田中先生と石津@RJCの御指摘
のOpenTransport1.1Jみたいですね

本当にたすかりましたー