このページは福井県立大学の田中求之が2006年1月まで運用していた Mac のサーバ運用に関する会議室 「Web Scripter's Meeting」の記録です。情報が古くなっている可能性がありますのでご注意ください。

NetCloakとの共存について

発言者:林 博保
( Date Monday, January 29, 1996 15:18:34 )


現在,PowerMac8100/80とQuadra 700でサーバを立ち上げて
おります(www.bhport.co.jp)。Internet User Vol.2 No.3 Mar 1986号の
牧原さんの記事で田中さんのOSAXの事を知りアクセスいたしました。
当方ではNetCloakを使用して日付やアクセス数などを表示させております。
実はNetFormsも使ってみたのですが,この会議室のようなフォームを作成
すると,「投稿」ボタンを押すと同時にサーバがフリーズしてしまい
使えません。Maxum社へメールを出しても何の回答も得られず困って
おりました。田中さんのOSAXを使わせて頂く場合,
NetCloakと共存しても大丈夫でしょうか(mailtoフォームで送られてくる
メールの日本語解読に苦労していますので是非とも田中さんのOSAXを
使いたいのですが)。
(AppleScript勉強中の初心者より)
email: hiro@bhport.co.jp

田中求之 さんからのコメント
( Monday, January 29, 1996 18:19:20 )

>。田中さんのOSAXを使わせて頂く場合,
>NetCloakと共存しても大丈夫でしょうか

普通に使うのであればまったく問題ありません。私のさーばーでも NetCloak は使って
いますよ。ハングアップなどの症状が出たことは1度もありません。


なお、CGI のページで NetCloak のコマンドを使うには、ちょっとしたテクニック
が必要になります(いうほど大げさなものではありませんが)。


田中求之 さんからのコメント
( Monday, January 29, 1996 18:22:03 )

mailto で送られてくる FORM のメールの読解には、ClipDecoderという
デコード用のスタックも作ってありますので、よかったらそっちもお試しください。

笹部 晃秀 さんからのコメント
( Thursday, October 31, 1996 11:50:53 )

もしわかれば教えてください。
WebstarでWWWサーバーを立ち上げていて、NetCloakと田中さんの
CGI kitを使わせていただいています。そこで今ちょっとした問題に
あたっています。
サーバーにしてあるMacintoshでFinder操作(例えばウインドウを閉じる等)
をするとNetCloakがエラーを起こして再起動になってしまうんです。いつも
起こる訳ではないんですが、たまにさわるとエラーが出ます。エラータイプは
11です。
環境は
機種:PowerMacintosh 7600/120
OS  :漢字Talk 7.5.3
メモリ:48MB
WebSTAR割り当てメモリ:6MB
NetCloak割り当てメモリ:1.5MB
です。あとWebカウンター用に雑誌の付録についていたCount WWWebula CGI
version 1.1というのを使っています。
なにぶん初心者なものでわからないことだらけです。よいアドバイスがあれば
お願いします。

田中求之 さんからのコメント
( Thursday, October 31, 1996 12:12:48 )

WebSTAR と NetCloak は最新版ですか? (WebSTAR = 1.3.1, NetCloak = 2.1)

それと、NetCloak は CGI として使っていらっしゃるようですが、Plugin で
試してみてください。 WebSTAR でしたら、Plugin で使った方が圧倒的に
速いですよ。(Count WWWebula も Plugin 版が出てます)

それから、TYPE=11 のシステムエラーが出るのは NetCloak だけですか?
他のソフトで出ることはないですか?

笹部 晃秀 さんからのコメント
( Friday, November 01, 1996 11:51:32 )

WebSTARとNetCloakのバージョンは(WebSTAR=J1-1.2.4 NetCloak=2.0.1)でした。ちょっと古いんですね。
それで(www.starnine.com)から新しいバージョンをダウンロードできるようなのですが今使っている日本語版
のものをそのままアップデートして大丈夫なのでしょうか?アップデートすればPluginの機能が使えるようにな
るんですよね。
 TYPE=11のシステムエラーが出るのはNetCloakだけです。

田中求之 さんからのコメント
( Friday, November 01, 1996 14:12:45 )

WebSTAR はぜひアップグレードしてください。ただし、日本語版のアップグレードは
SRA のホームページから入手してください。(英語版は日本語版のシリアルでは動きま
せん)。

1.3.1J の日本語版をダウンロードして、今のサーバーと取り替えれば、そのままで
OKです。 Plugin もばりばり使えるようになります(ただし、Plugin を使う
には、サーバーに割り当てるメモリーを増やす必要がありますが)。

また、NetCloak もアップグレードした方が良いと思います。 Type=11 のエラーの
原因がよくわからないのですが、2.1 はかなり長い間公開ベータテストを行っていた
バージョンですので、様々なバグが取れています。


ただし、Type=11 のエラーがこれで無くなるかどうかは、わかりませんが。

→  WebSTAR Home Page (SRA)

笹部 晃秀 さんからのコメント
( Friday, November 01, 1996 17:24:49 )

WebSTARをアップグレードしました。そうしたらNetCloakのエラーも出なくなったんですが、
念のためNetCloakのアップグレードしておきます。ありがとうございました。
 それでまた質問なんですがNetCloakをダウンロードする際にRushHourも一緒にダウンロード
しました。RushHourって画像の送出速度を上げてサーバーの反応を向上させるツールですよね。
それで、英語のガイドを何となくで読みながらセットアップを行ったんですがどうも効果が感じ
られません。セットアップが間違えてるのでしょうか。それともこんなものなんでしょうか。
 今の状態はWebSTARと同じフォルダにRushHourをコピーして「Network」は「OpenTransport」、
を選択してます。そして「Start」したんですけど、それでいいんでしょうか?

笹部 晃秀 さんからのコメント
( Friday, November 01, 1996 17:27:22 )

WebSTARをアップグレードしました。そうしたらNetCloakのエラーも出なくなったんですが、
念のためNetCloakのアップグレードしておきます。ありがとうございました。
 それでまた質問なんですがNetCloakをダウンロードする際にRushHourも一緒にダウンロード
しました。RushHourって画像の送出速度を上げてサーバーの反応を向上させるツールですよね。
それで、英語のガイドを何となくで読みながらセットアップを行ったんですがどうも効果が感じ
られません。セットアップが間違えてるのでしょうか。それともこんなものなんでしょうか。
 今の状態はWebSTARと同じフォルダにRushHourとRushHourFilesフォルダをコピーして
「Network」は「OpenTransport」、を選択してます。そして「Start」したんですけど、そ
れでいいんでしょうか?

笹部 晃秀 さんからのコメント
( Friday, November 01, 1996 17:37:35 )

WebSTARをアップグレードしました。そうしたらNetCloakのエラーも出なくなったんですが、
念のためNetCloakのアップグレードしておきます。ありがとうございました。
それで今度はWebSTARのステータスに次のメッセージが出ます。
「警告!"no access"ファイルが、アクションに処理されています。このアクションが NO_ACCESS
 CGI/Plug-inメッセージを適切に処理しているかどうか確認してください。」
これはどう解消すればいいんでしょうか。初心者の私に教えてください。
 それともう一つ質問なんですがNetCloakをダウンロードする際にRushHourも一緒にダウンロード
しました。RushHourって画像の送出速度を上げてサーバーの反応を向上させるツールですよね。
それで、英語のガイドを何となくで読みながらセットアップを行ったんですがどうも効果が感じ
られません。セットアップが間違えてるのでしょうか。それともこんなものなんでしょうか。
 今の状態はWebSTARと同じフォルダにRushHour OT1.1とRushHourFilesフォルダをコピー
して「Network」は「OpenTransport」、を選択してます。そして「Start」したんですけど、
それでいいんでしょうか?

笹部 晃秀 さんからのコメント
( Friday, November 01, 1996 17:40:29 )

WebSTARをアップグレードしました。そうしたらNetCloakのエラーも出なくなったんですが、
念のためNetCloakのアップグレードしておきます。ありがとうございました。
それで今度はWebSTARのステータスに次のメッセージが出ます。
「警告!"no access"ファイルが、アクションに処理されています。このアクションが NO_ACCESS
 CGI/Plug-inメッセージを適切に処理しているかどうか確認してください。」
これはどう解消すればいいんでしょうか。初心者の私に教えてください。
 それともう一つ質問なんですがNetCloakをダウンロードする際にRushHourも一緒にダウンロード
しました。RushHourって画像の送出速度を上げてサーバーの反応を向上させるツールですよね。
それで、英語のガイドを何となくで読みながらセットアップを行ったんですがどうも効果が感じ
られません。セットアップが間違えてるのでしょうか。それともこんなものなんでしょうか。
 今の状態はWebSTARと同じフォルダにRushHour OT1.1とRushHourFilesフォルダをコピー
して「Network」は「OpenTransport」、を選択してます。そして「Start」したんですけど、
それでいいんでしょうか?

笹部 晃秀 さんからのコメント
( Friday, November 01, 1996 17:41:01 )

WebSTARをアップグレードしました。そうしたらNetCloakのエラーも出なくなったんですが、
念のためNetCloakのアップグレードしておきます。ありがとうございました。
それで今度はWebSTARのステータスに次のメッセージが出ます。
「警告!"no access"ファイルが、アクションに処理されています。このアクションが NO_ACCESS
 CGI/Plug-inメッセージを適切に処理しているかどうか確認してください。」
これはどう解消すればいいんでしょうか。初心者の私に教えてください。
 それともう一つ質問なんですがNetCloakをダウンロードする際にRushHourも一緒にダウンロード
しました。RushHourって画像の送出速度を上げてサーバーの反応を向上させるツールですよね。
それで、英語のガイドを何となくで読みながらセットアップを行ったんですがどうも効果が感じ
られません。セットアップが間違えてるのでしょうか。それともこんなものなんでしょうか。
 今の状態はWebSTARと同じフォルダにRushHour OT1.1とRushHourFilesフォルダをコピー
して「Network」は「OpenTransport」、を選択してます。そして「Start」したんですけど、
それでいいんでしょうか?

笹部 晃秀 さんからのコメント
( Friday, November 01, 1996 17:42:34 )

WebSTARをアップグレードしました。そうしたらNetCloakのエラーも出なくなったんですが、
念のためNetCloakのアップグレードしておきます。ありがとうございました。
それで今度はWebSTARのステータスに次のメッセージが出ます。
「警告!"no access"ファイルが、アクションに処理されています。このアクションが NO_ACCESS
 CGI/Plug-inメッセージを適切に処理しているかどうか確認してください。」
これはどう解消すればいいんでしょうか。初心者の私に教えてください。
 それともう一つ質問なんですがNetCloakをダウンロードする際にRushHourも一緒にダウンロード
しました。RushHourって画像の送出速度を上げてサーバーの反応を向上させるツールですよね。
それで、英語のガイドを何となくで読みながらセットアップを行ったんですがどうも効果が感じ
られません。セットアップが間違えてるのでしょうか。それともこんなものなんでしょうか。
 今の状態はWebSTARと同じフォルダにRushHour OT1.1とRushHourFilesフォルダをコピー
して「Network」は「OpenTransport」、を選択してます。そして「Start」したんですけど、
それでいいんでしょうか?

笹部 晃秀 さんからのコメント
( Friday, November 01, 1996 17:52:25 )

WebSTARをアップグレードしました。そうしたらNetCloakのエラーも出なくなったんですが、
念のためNetCloakのアップグレードしておきます。ありがとうございました。
それで今度はWebSTARのステータスに次のメッセージが出ます。
「警告!"no access"ファイルが、アクションに処理されています。このアクションが NO_ACCESS
 CGI/Plug-inメッセージを適切に処理しているかどうか確認してください。」
これはどう解消すればいいんでしょうか。初心者の私に教えてください。
 それともう一つ質問なんですがNetCloakをダウンロードする際にRushHourも一緒にダウンロード
しました。RushHourって画像の送出速度を上げてサーバーの反応を向上させるツールですよね。
それで、英語のガイドを何となくで読みながらセットアップを行ったんですがどうも効果が感じ
られません。セットアップが間違えてるのでしょうか。それともこんなものなんでしょうか。
 今の状態はWebSTARと同じフォルダにRushHour OT1.1とRushHourFilesフォルダをコピー
して「Network」は「OpenTransport」、を選択してます。そして「Start」したんですけど、
それでいいんでしょうか?

田中求之 さんからのコメント
( Friday, November 01, 1996 18:14:26 )

NetCloak をどのような設定で使っていますか? もしすべての .html ファイルを
処理させるように設定していると、確かおっしゃるようなエラーが出たと思います。
この場合は、NetCloak を .nclk のファイルだけを処理するように切り替えるか、
あるいは NO ACCESS のファイルの拡張子を変更して再登録することになります。

RushHour は、基本的には、別のマックで使ってこそ威力の出るソフトです。リリース
当初、私もいろいろと試してみましたが、同一のマックで WebSTAR と RushHour を
動かしても、さほど効果はありません。画像などのファイルを、別のマックで動かして
いる RushHour に任せる、という2台構成のシステムを組んだときにパワーを発揮
するようですね。

笹部 晃秀 さんからのコメント
( Tuesday, November 05, 1996 09:10:39 )

ごめんなさい。同じメッセージをいっぱい送ってしまいました。
こういう時ってeasyBBSで「メッセージの削除ができればないいな」
と思ったりします。